VS:SetObjPropCharVS

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See VS:Object Events.

FUNCTION SetObjPropCharVS(
PropertyID :LONGINT;
PropertyVal :CHAR) :BOOLEAN;
def vs.SetObjPropCharVS(PropertyID, PropertyVal):
    return BOOLEAN

Parameters

PropertyID LONGINT
PropertyVal CHAR

Remarks

[ptr 09/24/2019]

CONST
  {ObjPropCharVS}
  kObjProp_SpecialEdit = 3; {PropertyID}
  kObjProp_SpecialEdit_Custom = '1'; {PropertyVal}

  kObjProp_WidgetGroupMode = 81; {PropertyID}
  kPbjProp_WidgetGroupMode_Automatic = '2'; {PropertyVal}
# ObjPropCharVS
kObjProp_SpecialEdit = 3  # PropertyID
kObjProp_SpecialEdit_Custom = "1"  # PropertyVal

kObjProp_WidgetGroupMode = 81  # PropertyID
kPbjProp_WidgetGroupMode_Automatic = "2"  # PropertyVal

Version

Availability: from All Versions

This is drop-in function.