VS:SetObjPropCharVS

From Vectorworks Developer
Revision as of 17:54, 13 May 2021 by CBM-c- (talk | contribs) (fix old link to vectorlab)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See VS:Object Events.

FUNCTION SetObjPropCharVS(
PropertyID :LONGINT;
PropertyVal :CHAR) :BOOLEAN;
def vs.SetObjPropCharVS(PropertyID, PropertyVal):
    return BOOLEAN

Parameters

PropertyID LONGINT
PropertyVal CHAR

Remarks

[ptr 09/24/2019]

CONST
  {ObjPropCharVS}
  kObjProp_SpecialEdit = 3; {PropertyID}
  kObjProp_SpecialEdit_Custom = '1'; {PropertyVal}

  kObjProp_WidgetGroupMode = 81; {PropertyID}
  kPbjProp_WidgetGroupMode_Automatic = '2'; {PropertyVal}
# ObjPropCharVS
kObjProp_SpecialEdit = 3  # PropertyID
kObjProp_SpecialEdit_Custom = "1"  # PropertyVal

kObjProp_WidgetGroupMode = 81  # PropertyID
kPbjProp_WidgetGroupMode_Automatic = "2"  # PropertyVal

Version

Availability: from All Versions

This is drop-in function.