VS:SetObjExpandTexture

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetObjExpandTexture sets the "expanded" state of the referenced objects' texture. When a texture is expanded, different components of an object can have different textures.

PROCEDURE SetObjExpandTexture(
obj :HANDLE;
expanded :BOOLEAN);
def vs.SetObjExpandTexture(obj, expanded):
    return None

Parameters

obj HANDLE Handle to object.
expanded BOOLEAN Use expanded textures setting.

Remarks

Sets whether three or just a single texture is applied to this object (can be up to three for walls or two for roofs).

Version

Availability: from VectorWorks8.0