VS:SetMtlPenForeColor

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the pen foreground color of the specified material. The color must be specified using the RGB components of the desired color. RGB values are in the range of 0~65535.

PROCEDURE SetMtlPenForeColor(
material :HANDLE;
color :LONGINT);
def vs.SetMtlPenForeColor(material, color):
    return None

Parameters

material HANDLE Handle to material.
color LONGINT RGB color value.

Remarks

Sets the pen foreground color of the material.

Example

ColorIndexToRGB(214,cRed,cGrn,cBlu);
SetMtlPenForeColor(mtlHandle,cRed,cGrn,cBlu);

Version

Availability: from Vectorworks 2021