VS:SetLineTypeAttriData

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set current choices for the line attribute dialog control. Both the line type and the line weight in mils can be specified.

PROCEDURE SetLineTypeAttriData(
dialogID :LONGINT;
itemID :LONGINT;
lineType :LONGINT;
lineWeight :INTEGER);
def vs.SetLineTypeAttriData(dialogID, itemID, lineType, lineWeight):
    return None

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the line attribute control.
lineType LONGINT The internal index (reference number) of the line type.
lineWeight INTEGER The line weight.The value is in mils.

Version

Availability: from Vectorworks 2015