VS:SetLightInfo

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the attributes of the referenced light object.

PROCEDURE SetLightInfo(
h :HANDLE;
lightType :INTEGER;
brightness :INTEGER;
isOn :BOOLEAN;
castShadow :BOOLEAN);
def vs.SetLightInfo(h, lightType, brightness, isOn, castShadow):
    return None

Parameters

h HANDLE Handle to light.
lightType INTEGER Light type.
brightness INTEGER Brightness of light.
isOn BOOLEAN On-off status of light.
castShadow BOOLEAN Shadow casting status of light.

Version

Availability: from MiniCAD7.0