VS:SetLightFalloff

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetLightFalloff sets the fall off attributes for the referenced light object.

Table - Light Falloff Types
Falloff Type Constant
None 0
Normal 1
Smooth 2
Sharp 3
PROCEDURE SetLightFalloff(
light :HANDLE;
distFalloff :INTEGER;
angFalloff :INTEGER);
def vs.SetLightFalloff(light, distFalloff, angFalloff):
    return None

Parameters

light HANDLE Handle to light.
distFalloff INTEGER Distance falloff value.
angFalloff INTEGER Angular falloff value.

Remarks

Sets the falloff functions for the light. 0 = None, 1 = Normal, 2 = Smooth, 3 = Sharp (angular falloff only).

Version

Availability: from MiniCAD 7.0.1