VS:SetLevelTypeName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the name of the nth Level Type in the file. For example, if 3 is passed in, it will set the name of the 3rd Level Type in the file.

FUNCTION SetLevelTypeName(
index :INTEGER;
name :STRING) : BOOLEAN;
def vs.SetLevelTypeName(index, name):
    return BOOLEAN

Parameters

index INTEGER The index of the level type whose name is being set.
name STRING The name the indicated level type should be set to.

Return Value

Whether the setting of the name of the level type succeeded. It will fail if passed an invalid index. The name must not have more than 63 characters and must not be used by another level type in the file.

Example

VAR

result : BOOLEAN;

BEGIN

result := SetLayerLevelTypeName(2, "Subfloor");

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:GetNumLayerLevelTypes | VS:GetLevelTypeName

VS Functions:

[[VS:GetNumLayerLevelTypes]]

| [[VS:GetLevelTypeName]]