VS:SetLevelElevation

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the elevation of a Story Level relative to its Story.

FUNCTION SetLevelElevation(
storyHandle :HANDLE;
levelType :STRING;
newElevation :REAL) : BOOLEAN;
def vs.SetLevelElevation(storyHandle, levelType, newElevation):
    return BOOLEAN

Parameters

storyHandle HANDLE The handle of the Story with the desired Story Level.
levelType STRING The level type of the Story Level to change the elevation of.
newElevation REAL The new elevation for the Story Level.

Return Value

Whether the Story Level was found and successfully updated.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:CreateStory | VS:AddStoryLevel | VS:RemoveStoryLevel | VS:AddLevelFromTemplate | VS:GetLevelElevation

VS Functions:

[[VS:CreateStory]] | [[VS:AddStoryLevel]] | [[VS:RemoveStoryLevel]] | [[VS:AddLevelFromTemplate]]

| [[VS:GetLevelElevation]]