VS:SetLayerRenderMode

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the render mode of the referenced layer.

PROCEDURE SetLayerRenderMode(
theLayer :HANDLE;
newRenderMode :INTEGER;
immediate :BOOLEAN;
doProgress :BOOLEAN);
def vs.SetLayerRenderMode(theLayer, newRenderMode, immediate, doProgress):
    return None

Parameters

theLayer HANDLE Handle of the layer
newRenderMode INTEGER New render mode to set
immediate BOOLEAN If true, then all rendering will take place before the call returns. Otherwise, any rendering that can take place in the background will be postponed until program execution re-enters the main event loop
doProgress BOOLEAN controls whether progress information is displayed during the operation

Remarks

newRenderMode index corresponds to those listed above in getlayerrendermode call.

RenderNow - controls whether the specified layer will be re-rendered when the render mode is changed or not.

Display progress -  ?? This might control whether the screen updates as it is rendering or not. I haven't been able to figure out a definite effect of this parameter.

Version

Availability: from VectorWorks10.0