VS:SetLayerAmbientInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetLayerAmbientInfo sets the attribute values for the ambient light object of the referenced layer.

PROCEDURE SetLayerAmbientInfo(
layer :HANDLE;
isOn :BOOLEAN;
brightness :INTEGER);
def vs.SetLayerAmbientInfo(layer, isOn, brightness):
    return None

Parameters

layer HANDLE Handle to layer.
isOn BOOLEAN On-off status of ambient light
brightness INTEGER Brightness of ambient light.

Remarks

brightness is a percentage value

Version

Availability: from VectorWorks8.0