VS:SetLScale

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetLScale sets the scale of the referenced layer.

Calculating the Scale:

To calculate the scale parameter from an architecural scale, the following formula may be used:

denominator/numerator * true size(in inches) = ActualSize

For example, to calculate a scale of 3/8"=1'-0", the scale parameter would be 8/3 *12 = 32.

PROCEDURE SetLScale(
h :HANDLE;
scale :REAL);
def vs.SetLScale(h, scale):
    return None

Parameters

h HANDLE Handle to layer.
scale REAL Scale value for layer.

Example

VectorScript

SetLScale(HandleToLayer,96);
{sets the referenced layer to a scale of 1/8" = 1'}

Python


Version

Availability: from MiniCAD6.0