VS:SetLSN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(add remark)
(2 intermediate revisions by 2 users not shown)
Line 8: Line 8:
Procedure SetLSN sets the linestyle of the referenced object.<BR>
Procedure SetLSN sets the linestyle of the referenced object.<BR>
<BR>
<BR>
If the value is in the range 0 to 71, the specified fill pattern is applied as the linestyle; a negative value will apply the line type whose index is the negative of the value.</desc>
If the value is in the range 0 to 71, the specified fill pattern is applied as the linestyle; a negative value will apply the line type resource whose internal index is the negative of the value.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 38: Line 38:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): Expects a name list index, while the older routine [[VS:GetLS]] expected a dash style index.
 
<code lang="vs">
IF GetObject('ISO-02 Dashed') <> NIL THEN
SetLSN(FSActLayer, -Name2Index('ISO-02 Dashed')); { sets the first selected object to 'ISO-02 Dashed' if the style is present }
</code>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 16:46, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetLSN sets the linestyle of the referenced object.


If the value is in the range 0 to 71, the specified fill pattern is applied as the linestyle; a negative value will apply the line type resource whose internal index is the negative of the value.

PROCEDURE SetLSN(
h :HANDLE;
ls :LONGINT);
def vs.SetLSN(h, ls):
    return None

Parameters

h HANDLE Handle to object.
ls LONGINT Linestyle to apply to object.

Remarks

(Orso 2016.02.29): Expects a name list index, while the older routine VS:GetLS expected a dash style index.

IF GetObject('ISO-02 Dashed') <> NIL THEN
	SetLSN(FSActLayer, -Name2Index('ISO-02 Dashed')); { sets the first selected object to 'ISO-02 Dashed' if the style is present }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:GetLSN

VS Functions: [[VS:GetLSN]]