VS:SetLBSelection

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Selects the specified range of items within a List Browser dialog control.

FUNCTION SetLBSelection(
dialogID :LONGINT;
componentID :LONGINT;
firstItemIndex :INTEGER;
lastItemIndex :INTEGER;
select :BOOLEAN) : BOOLEAN;
def vs.SetLBSelection(dialogID, componentID, firstItemIndex, lastItemIndex, select):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
firstItemIndex INTEGER the first row of the range to select
lastItemIndex INTEGER the last row of the range to select
select BOOLEAN select or deselect

Return Value

True for success, false otherwise.

Version

Availability: from VectorWorks11.0