VS:SetLBNumericItemInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets numeric data for item.

FUNCTION SetLBNumericItemInfo(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
itemString :STRING;
itemNumVal :REAL;
imageIndex :INTEGER) : BOOLEAN;
def vs.SetLBNumericItemInfo(dialogID, componentID, itemIndex, subItemIndex, itemString, itemNumVal, imageIndex):
    return BOOLEAN

Parameters

dialogID LONGINT ID of the dialog that contains the list browser.
componentID LONGINT ID of the list browser control
itemIndex INTEGER the item index
subItemIndex INTEGER the subitem index
itemString STRING the item text
itemNumVal REAL the item numeric value
imageIndex INTEGER the item image list index

Version

Availability: from Vectorworks 2013