VS:SetLBMultImageIndexes

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See SetLBImageIndexes for a replacement.

Sets the index of the images within the list browser multi image display.

FUNCTION SetLBMultImageIndexes(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
imageIndex0 :INTEGER;
imageIndex1 :INTEGER;
imageIndex2 :INTEGER) : BOOLEAN;
def vs.SetLBMultImageIndexes(dialogID, componentID, itemIndex, subItemIndex, imageIndex0, imageIndex1, imageIndex2):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
imageIndex0 INTEGER the 'ics8' resource index of the first image
imageIndex1 INTEGER the 'ics8' resource index of the second image
imageIndex2 INTEGER the 'ics8' resource index of the third image

Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012