VS:SetLBItemPatternIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified list browser item's pattern index.

FUNCTION SetLBItemPatternIndex(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
patIndex :INTEGER) : BOOLEAN;
def vs.SetLBItemPatternIndex(dialogID, componentID, itemIndex, subItemIndex, patIndex):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
patIndex INTEGER The pattern index of this item. Value from [1..71] see VS:Function Reference Appendix#Fill Patterns

Example

VectorScript

SetupDialogC: BEGIN
  tmp := InsertLBColumn( dialog, kListBrowser, 0, 'one', 60 );
  tmp := InsertLBColumn( dialog, kListBrowser, 1, 'two', 60 );
  tmp := InsertLBItem( dialog, kListBrowser, 0, 'pat' );

  boo := SetLBControlType( dialog, kListBrowser, 1, 5 );
  boo := SetLBItemDisplayType( dialog, kListBrowser, 1, 1 );

  boo := SetLBColumnOwnerDrawnType( dialog, kListBrowser, 0, 1, 3 );
  boo := SetLBItemPatternIndex( dialog, kListBrowser, 0, 1, 9 );
  boo := SetLBItemFillForeColor( dialog, kListBrowser, 0, 1,   0, 0, 0 );
  boo := SetLBItemFillBackColor( dialog, kListBrowser, 0, 1,   255, 255, 255 );
END;

Python


Version

Availability: from Vectorworks 2010

See Also

VS:GetLBItemPatternIndex | VS:SetLBItemFillForeColor | VS:SetLBItemFillBackColor

VS:SetLBControlType | VS:SetLBItemDisplayType | VS:SetLBColumnOwnerDrawnType | VS:SetLBItemPatternIndex

[[VS:GetLBItemPatternIndex]] | [[VS:SetLBItemFillForeColor]] | [[VS:SetLBItemFillBackColor]] [[VS:SetLBControlType]] | [[VS:SetLBItemDisplayType]] | [[VS:SetLBColumnOwnerDrawnType]] | [[VS:SetLBItemPatternIndex]]