VS:SetLBImageIndexes

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the images for the list browser row, Replaces SetLBMultImageIndexes

FUNCTION SetLBImageIndexes(
dialogID :LONGINT;
controlID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
imageSpecifier0 :DYNARRAY[] of CHAR;
imageSpecifier1 :DYNARRAY[] of CHAR;
imageSpecifier2 :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.SetLBImageIndexes(dialogID, controlID, itemIndex, subItemIndex, imageSpecifier0, imageSpecifier1, imageSpecifier2):
    return BOOLEAN

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier of the control to be updated.
itemIndex INTEGER
subItemIndex INTEGER
imageSpecifier0 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier1 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier2 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012