VS:SetLBEditDisplayType

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets edit display type for list items in specified column.

FUNCTION SetLBEditDisplayType(
dialogID :LONGINT;
componentID :LONGINT;
columnIndex :INTEGER;
displayType :INTEGER) : BOOLEAN;
def vs.SetLBEditDisplayType(dialogID, componentID, columnIndex, displayType):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
columnIndex INTEGER the index of the column
displayType INTEGER the display type to be set (0: Text Only, 1: Icon Only, 3: Text and Icon)

Remarks

How is this different from VS:SetLBItemDisplayType? Declaration and description are almost identical. Both operate on columns. What is meant with 'edit' and with 'display'?

Version

Availability: from VectorWorks11.0