VS:SetLBEditDisplayType

From Vectorworks Developer
Revision as of 21:51, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets edit display type for list items in specified column.

FUNCTION SetLBEditDisplayType(
dialogID :LONGINT;
componentID :LONGINT;
columnIndex :INTEGER;
displayType :INTEGER) : BOOLEAN;
def vs.SetLBEditDisplayType(dialogID, componentID, columnIndex, displayType):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
columnIndex INTEGER the index of the column
displayType INTEGER the display type to be set (0: Text Only, 1: Icon Only, 3: Text and Icon)

Remarks

How is this different from VS:SetLBItemDisplayType? Declaration and description are almost identical. Both operate on columns. What is meant with 'edit' and with 'display'?

Version

Availability: from VectorWorks11.0