VS:SetLBControlType

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets control type for column.

FUNCTION SetLBControlType(
dialogID :LONGINT;
componentID :LONGINT;
columnIndex :INTEGER;
controlType :INTEGER) : BOOLEAN;
def vs.SetLBControlType(dialogID, componentID, columnIndex, controlType):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
columnIndex INTEGER the index of the column
controlType INTEGER the control type to be set (1: Static, 2: Radio, 3: Multi State, 4: Single Instance Icon [See Organization Dialog active element column], 5: Static Icon, 6: Number, 7: Multiple Icons)

Version

Availability: from VectorWorks11.0