VS:SetLBColumnOwnerDrawnType

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the list browser column's owner drawn type.

FUNCTION SetLBColumnOwnerDrawnType(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
ownerDrawnType :INTEGER) : BOOLEAN;
def vs.SetLBColumnOwnerDrawnType(dialogID, componentID, itemIndex, subItemIndex, ownerDrawnType):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
ownerDrawnType INTEGER None - 0

Remarks

Pattern and pattern rect are not quite supported under VW 12.5 and 12.5.1. Setting a LB cell to this type will load an artifact of a pattern. The image loaded is by default random and stretches on Mac (not on PC). A pattern shouldn't stretch according to the width of the LB cell, should be bound to the screen resolution.

There is to my knowledge no way to control the pattern loaded. A corresponding function for setting or retriving the pattern index is still missing in the currently published VS version. In the SDK there are SDK:GS_SetListBrowserItemPatternIndex and SDK:GS_GetListBrowserItemPatternIndex.

Version

Availability: from VectorWorks12.0