VS:SetLBColumnOwnerDrawnType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (add remark)
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Pattern and pattern rect are not quite supported under VW 12.5 and 12.5.1. Setting a LB cell to this type will load an artifact of a pattern. The image loaded is by default random and stretches on Mac (not on PC). A pattern shouldn't stretch according to the width of the LB cell, should be bound to the screen resolution.
([[User:Orso.b.schmid|Orso]], 2015.12.19):
Pattern and pattern rects are supported also on mac since VW 15 (2010). Use [[VS:SetLBItemPatternIndex]].
 
([[User:Orso.b.schmid|Orso]], 2007.05.16):
Pattern and pattern rect are not quite supported under VW 12.5 and 12.5.1. Setting a LB cell to this type will only load the artifact of a pattern. The image loaded is by default random and stretches on Mac (not on PC). A pattern shouldn't stretch according to the width of the LB cell, should be bound to the screen resolution.


There is to my knowledge no way to control the pattern loaded.
There is to my knowledge no way to control the pattern loaded.
Line 67: Line 71:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Revision as of 04:30, 19 December 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the list browser column's owner drawn type.

FUNCTION SetLBColumnOwnerDrawnType(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
ownerDrawnType :INTEGER) : BOOLEAN;
def vs.SetLBColumnOwnerDrawnType(dialogID, componentID, itemIndex, subItemIndex, ownerDrawnType):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
ownerDrawnType INTEGER None - 0

Remarks

(Orso, 2015.12.19):

Pattern and pattern rects are supported also on mac since VW 15 (2010). Use VS:SetLBItemPatternIndex.

(Orso, 2007.05.16): Pattern and pattern rect are not quite supported under VW 12.5 and 12.5.1. Setting a LB cell to this type will only load the artifact of a pattern. The image loaded is by default random and stretches on Mac (not on PC). A pattern shouldn't stretch according to the width of the LB cell, should be bound to the screen resolution.

There is to my knowledge no way to control the pattern loaded. A corresponding function for setting or retriving the pattern index is still missing in the currently published VS version. In the SDK there are SDK:GS_SetListBrowserItemPatternIndex and SDK:GS_GetListBrowserItemPatternIndex.

Version

Availability: from VectorWorks 12.0