VS:SetItemClickable

From Vectorworks Developer
Revision as of 14:54, 26 April 2018 by MaKro (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified item to generate events when clicked. Currently only static text and images are supported.

Remark: Use in the dialogs setup event handler. Changes the cursor if the mouse is over the item to indicate its clickability.

PROCEDURE SetItemClickable(
dialogID :LONGINT;
componentID :LONGINT;
clickable :BOOLEAN);
def vs.SetItemClickable(dialogID, componentID, clickable):
    return None

Parameters

dialogID LONGINT
componentID LONGINT
clickable BOOLEAN

Version

Availability: from Vectorworks 2010