VS:SetImagePopupSelectedItem

From Vectorworks Developer
Revision as of 21:51, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the selected image popup item. The itemIndex parameter is 1-based.

PROCEDURE SetImagePopupSelectedItem(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER);
def vs.SetImagePopupSelectedItem(dialogID, componentID, itemIndex):
    return None

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.
itemIndex INTEGER Index to item to select.

Example

VectorScript

SetImagePopupSelectedItem(dialogID, componentID, 4);

Python


Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObject | VS:GetImagePopupObjectItemIndex | VS:GetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObject]] | [[VS:GetImagePopupObjectItemIndex]] | [[VS:GetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]