VS:SetGradientSpotPosition

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the spot position of the specified gradient segment.

Note: you must use a variable, initialized to the segment index, to pass as a parameter. After the data has been set, this variable will contain the index of the segment, which may have changed because of the spot position specified.

PROCEDURE SetGradientSpotPosition(
gradient :HANDLE;
VAR segmentIndex :INTEGER;
position :REAL);
def vs.SetGradientSpotPosition(gradient, segmentIndex, position):
    return segmentIndex

Parameters

gradient HANDLE Gradient that contains the segment.
segmentIndex INTEGER Segment for which to set the data.
position REAL Position of the segment's color spot relative to left-most point of the gradient.

Example

VectorScript

SetGradientSpotPosition(gradientHandle, segmentIndex, 0.9);

Python


Version

Availability: from VectorWorks10.0