VS:SetGradientSpotColor

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the spot color of the specified gradient segment.

PROCEDURE SetGradientSpotColor(
gradient :HANDLE;
segmentIndex :INTEGER;
red :LONGINT;
green :LONGINT;
blue :LONGINT);
def vs.SetGradientSpotColor(gradient, segmentIndex, red, green, blue):
    return None

Parameters

gradient HANDLE Gradient that contains the segment.
segmentIndex INTEGER Segment for which to set the data.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.

Example

VectorScript

SetGradientSpotColor(gradientHandle, 4, 255, 255, 255);

Python


Version

Availability: from VectorWorks10.0