VS:SetGradientDataN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision: vw2015)
 
(No difference)

Latest revision as of 14:35, 18 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Note: you must use a variable, initialized to the segment index, to pass as a parameter. After the data has been set, this variable will contain the index of the segment, which may have changed because of the spot position specified.

PROCEDURE SetGradientDataN(
gradient :HANDLE;
VAR segmentIndex :INTEGER;
spotPosition :REAL;
midpointPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT;
opacity :INTEGER);
def vs.SetGradientDataN(gradient, segmentIndex, spotPosition, midpointPosition, red, green, blue, opacity):
    return segmentIndex

Parameters

gradient HANDLE Gradient that contains the segment.
segmentIndex INTEGER Segment for which to set the data.
spotPosition REAL Position of the segment's color spot relative to left-most point of the gradient.
midpointPosition REAL Position of the segment's midpoint relative to color spot immediately to left.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.
opacity INTEGER Opacity of the color spot.

Example

segmentIndex := 4;
SetGradientData(gradientHandle, segmentIndex, 0.9, 0.5, 255, 255, 255,100);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetGradientDataN | VS:InsertGradientData

VS Functions:

[[VS:GetGradientDataN]]

| [[VS:InsertGradientData]]