VS:SetGableAttributes/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根の中の、切り妻のドーマーを設定します。

PROCEDURE SetGableAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDepthDistance :REAL)Coordinate); bottomWidthDistance:REAL (Coordinate); overhangDistance:REAL (Coordinate); leftAngle:REAL; rightAngle:REAL);
def vs.SetGableAttributes(roofObject, dormerID, useHeight, heightDepthDistance, bottomWidthDistance, overhangDistance, leftAngle, rightAngle):
    return None

Parameters

roofObject HANDLE 屋根のハンドル
dormerID INTEGER ドーマーの番号
useHeight BOOLEAN 高さ設定の有無
heightDepthDistance REAL (Coordinate) 高さまたは厚み
bottomWidthDistance REAL (Coordinate) 下部の幅
overhangDistance REAL (Coordinate) 張り出し距離
leftAngle REAL 左側の傾斜角度
rightAngle REAL 右側の傾斜角度

Example

roofHandle:=CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45°0'0" ,2'0",10'0");
gabID:=CreateGableDormer(roofHandle);
SetGableAttributes(roofHandle,gabID,TRUE,6'0",10'0",2'0",#45°0'0",#45°0'0");
SetDormerAttributes(roofHandle,gabID,3,18'4",TRUE,3'0",63,FALSE,
3'0");
SetDormerThick(roofHandle, 2",1.83333");

Version

利用可能バージョン: VectorWorks8.0