VS:SetFillFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(reduced remark)
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:Orso.b.schmid| Orso]]: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with [[VS:RGBToColorIndex]]. See remarks under [[VS:SetPenFore]] for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index].


 
; Warning: SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.
 
</remark>
This Procedure will also accept a single INTEGER Color Palette Index value for the COLOR parameter.  See similar comment for SetFillBack.
 
 
 
SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it (up to VW 13).</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
SetFillFore(h, 65535, 0, 0);
SetFillFore(h, 65535, 0, 0);
</code>
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
vs.SetFillFore(h, (65535, 0, 0))
</code>
</code>
</sample>
</sample>

Revision as of 04:47, 19 May 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetFillFore sets the fill foreground color setting of the referenced object. RGB values are in the range of 0~65535.

PROCEDURE SetFillFore(
h :HANDLE;
color :LONGINT);
def vs.SetFillFore(h, color):
    return None

Parameters

h HANDLE Handle to object.
color LONGINT RGB color value.

Remarks

Orso: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Warning
SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.

Example

VectorScript

SetFillFore(h, 65535, 0, 0);

Python

vs.SetFillFore(h, (65535, 0, 0))

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]