VS:SetFillFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (Transfer Orso to _c_)
 
(2 intermediate revisions by the same user not shown)
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:CBM-c-|_c_]] 2015.05.19: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with [[VS:RGBToColorIndex]]. See remarks under [[VS:SetPenFore]] for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index].


 
; Warning: SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.
 
</remark>
This Procedure will also accept a single INTEGER Color Palette Index value for the COLOR parameter.  See similar comment for SetFillBack.
 
 
 
SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it (up to VW 13).</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
SetFillFore(h, 65535, 0, 0);
SetFillFore(h, 65535, 0, 39321); { using RGB values }
 
colorIndex := RGBToColorIndex(65535, 0, 39321);
SetFillFore(h, colorIndex); { using Color Index values }
</code>
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
vs.SetFillFore(h, (65535, 0, 39321)) # using RGB values


colorIndex = vs.RGBToColorIndex(65535, 0, 39321)
vs.SetFillFore(h, colorIndex) # using Color Index values
</code>
</code>
</sample>
</sample>

Latest revision as of 06:07, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetFillFore sets the fill foreground color setting of the referenced object. RGB values are in the range of 0~65535.

PROCEDURE SetFillFore(
h :HANDLE;
color :LONGINT);
def vs.SetFillFore(h, color):
    return None

Parameters

h HANDLE Handle to object.
color LONGINT RGB color value.

Remarks

_c_ 2015.05.19: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Warning
SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.

Example

VectorScript

SetFillFore(h, 65535, 0, 39321); { using RGB values }

colorIndex := RGBToColorIndex(65535, 0, 39321);
SetFillFore(h, colorIndex); { using Color Index values }

Python

vs.SetFillFore(h, (65535, 0, 39321)) # using RGB values

colorIndex = vs.RGBToColorIndex(65535, 0, 39321)
vs.SetFillFore(h, colorIndex) # using Color Index values

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]