VS:SetFillBack: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(reduce and update infos)
Line 37: Line 37:
<remark>
<remark>


 
[[User:Orso.b.schmid| Orso]]: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with [[VS:RGBToColorIndex]]. See remarks under [[VS:SetPenFore]] for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index].
 
; Warning: SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.
This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. (Tested in VW12.5 on a Mac).
</remark>
 
[[User:Orso.b.schmid| orso]]: Some time ago I wrote a page about this feature and others; see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index]. You'll find a list of all color routines accepting double variable type.
 
[[User:Orso.b.schmid| orso]]: SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it (up to VW 13).</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 03:38, 19 May 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetFillBack sets the fill background color setting of the specified object. RGB values are in the range of 0~65535.

PROCEDURE SetFillBack(
h :HANDLE;
color :LONGINT);
def vs.SetFillBack(h, color):
    return None

Parameters

h HANDLE Handle to object.
color LONGINT RGB color value.

Remarks

Orso: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Warning
SetFillBack, SetFillFore will remove the "ByClass" attribute of the PEN as well. Remember to parse for it and restore it.

Example

VectorScript

{ Sets the Fill Background to black }
SetFillBack(h, 0, 0, 0); { using rgb values }
SetFillBack(h, 255); { using color index, be careful with color indexes after VW12 }
{ Conversely, GetFillBack will only return RGB values. }

Python

vs.SetFillBack( h, (0, 0, 0) ) # using rgb values in a tuple
vs.SetFillBack( h, (65535, 0, 0) ) # red color - note that the values are 32-bit
vs.SetFillBack( h, (0xFFFF, 0, 0) ) # red color - or you can use hex numbers in python
vs.SetFillBack( h, 255 ) # using color index, be careful with color indexes after VW12

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]