VS:SetField

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetField updates the text in the specified text field. Static or editable fields may be updated using this call, which can only be used while the dialog is displayed on screen.

PROCEDURE SetField(
fieldID :INTEGER;
str :DYNARRAY[] of CHAR);
def vs.SetField(fieldID, str):
    return None

Parameters

fieldID INTEGER Item ID of dialog field to be updated.
str DYNARRAY[] of CHAR New string value for field.

Remarks

Note: deprecated from VW 15+, use SetItemText

Example

VectorScript

CASE whatSelected OF		
1:BEGIN
SetItemEnable(11,TRUE);
SetItemEnable(12,FALSE);
SetItemEnable(13,FALSE);
SetItemEnable(14,FALSE);
END;
2:BEGIN
SetField(11,'Use Class Settings');
SetItemEnable(11,TRUE);
SetField(12,'Use Layer Settings');
SetItemEnable(12,TRUE);
END;

Python


Version

Availability: from All Versions. Deprecated from VW 15+.