VS:SetEntityMatrix

From Vectorworks Developer
Revision as of 03:53, 1 April 2011 by Juliancarr (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the matrix of the plane for a planar object. If there is already a plane in the document with that matrix, the object will be set to be in that plane. Otherwise a new plane will be added to the document.

FUNCTION SetEntityMatrix(
objectHandle :HANDLE;
offsetX :REAL;
offsetY :REAL;
offsetZ :REAL;
rotationXAngle :REAL;
rotationYAngle :REAL;
rotationZAngle :REAL) : BOOLEAN;
def vs.SetEntityMatrix(objectHandle, offset, rotationXAngle, rotationYAngle, rotationZAngle):
    return BOOLEAN

Parameters

objectHandle HANDLE The object whose plane is being set.
offset REAL The X, Y and Z offsets of the plane in current document units.
rotationXAngle REAL The rotation of the plane about the X-axis in degrees.
rotationYAngle REAL The rotation of the plane about the Y-axis in degrees.
rotationZAngle REAL The rotation of the plane about the Z-axis in degrees.

Return Value

Returns true if the object passed is a planar object.

Version

Availability: from Vectorworks 2011