VS:SetDimStd

From Vectorworks Developer
Revision as of 21:56, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetDimStd changes the default dimension standard of a VectorWorks document.

Built-in dimension standards are specified using index values of 1 thru 9, corresponding to the dimension standard preference menu. Custom dimensions are specified using indexes 0 thru -8, with 0 being the first custom dimension standard, -1 being the second, and so on.

PROCEDURE SetDimStd(
whichStandard :INTEGER);
def vs.SetDimStd(whichStandard):
    return None

Parameters

whichStandard INTEGER Dimension standard constant.

Remarks

Changes the document's default dimension standard. The whichStandard parameter specifies which dimension standard to change it to. The nine built-in dimension standards are specified using indexes 1 thru 9, and correspond to the ordering in the dimension standard popup menu. Custom dimensions are specified using indexes 0 thru -8, with 0 being the first custom dimension standard, -1 being the second, and so on.

[sd 8/18/98]

Example

VectorScript

SetDimStd(2);

{sets the dimension standard to ASME}

Python


Version

Availability: from MiniCAD4.0