VS:SetDescriptionText

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the user-supplied description for an object.

Adds the description data node if one does not already exist.

FUNCTION SetDescriptionText(
hObject :HANDLE;
descriptionText :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.SetDescriptionText(hObject, descriptionText):
    return BOOLEAN

Parameters

hObject HANDLE Handle of the object for which the description should be set.
descriptionText DYNARRAY[] of CHAR The description text to be set for the object

Return Value

true if text was successfully set; false if error occurred.

Remarks

Added for T01363 to add descriptions for classes and layers.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetDescriptionText

VS Functions: [[VS:GetDescriptionText]]