VS:SetDefaultEndMarker

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets all properties of the document default end marker. Return TRUE if operation was successful.

FUNCTION SetDefaultEndMarker(
style :LONGINT;
angle :INTEGER;
size :REAL;
width :REAL;
thicknessBasis :INTEGER;
thickness :REAL;
visibility :BOOLEAN) : BOOLEAN;
def vs.SetDefaultEndMarker(style, angle, size, width, thicknessBasis, thickness, visibility):
    return BOOLEAN

Parameters

style LONGINT The marker style. (see comments for details)
angle INTEGER The marker angle in degrees. (0 to 90)
size REAL The marker size in page inches.
width REAL The marker width in page inches.
thicknessBasis INTEGER The marker thickness basis. ( see comments for details)
thickness REAL The marker thickness.
visibility BOOLEAN The marker visibility.

Example

VectorScript

PROCEDURE Example;
VAR
ok : BOOLEAN;
BEGIN
ok := SetDefaultEndMarker(2176, 15, 0.5, 0, 0, 2, TRUE);	
END;

RUN(Example);

Python


Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:SetDefaultBeginningMarker

VS Functions: [[VS:SetDefaultBeginningMarker]]