VS:SetDefGenStoryBound: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
(No difference)

Revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This will set the default generic story bound for a plugin that has the kObjXPropSupportGenericStoryLevel property.

FUNCTION SetDefGenStoryBound(
format :HANDLE;
boundType :INTEGER;
boundStory :INTEGER;
layerLevelType :STRING;
offSet :REAL) : BOOLEAN;
def vs.SetDefGenStoryBound(format, boundType, boundStory, layerLevelType, offSet):
    return BOOLEAN

Parameters

format HANDLE Handle of the parametric's format
boundType INTEGER Bounding type: 0 - LayerZ; 1 - DefaultWallHeight; 2 - Story
boundStory INTEGER The story for the bound. If 'boundStory' = 0 then it is the object's story. If 'boundStory' = 1 then it is the story above. If 'boundStory' = -1 then it is the story below.
layerLevelType STRING The layer type which defines this bound (e.g. "Ceiling").
offSet REAL The offset distance from the specified bound story.

Return Value

TRUE if successful. FALSE will be returned if input object isn't a format or isn't associated with a plugin that has the kObjXPropSupportGenericStoryLevel property set.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:GetDefGenStoryBound

VS Functions: [[VS:GetDefGenStoryBound]]