VS:SetDashStyleN

From Vectorworks Developer
Revision as of 15:01, 1 March 2016 by CBM-c- (talk | contribs) (wikify example, add remark)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetDashStyleN creates a new linestyle in a Vectorworks document. Parameter name defines the name of the linestyle, parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs defining the linestyle.


The linestyle is defined by up to five black/white length pairs, which are specified in parameters pair1 through pair5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs.

PROCEDURE SetDashStyleN(
name :STRING;
swt :BOOLEAN;
numPairs :INTEGER;
pair1 :REAL;
pair2 :REAL;
pair3 :REAL;
pair4 :REAL;
pair5 :REAL);
def vs.SetDashStyleN(name, swt, numPairs, pair1, pair2, pair3, pair4, pair5):
    return None

Parameters

name STRING
swt BOOLEAN
numPairs INTEGER
pair1 REAL
pair2 REAL
pair3 REAL
pair4 REAL
pair5 REAL

Remarks

Orso, 2014.04.08: It creates a named dash style definition. The name will appear also in the name list.

Example

SetDashStyleN(True, 0, 1", 1/4", 1/4", 1/4");

Version

Availability: from Vectorworks 2010