VS:SetDashStyleN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix faulty example)
(expand)
Line 68: Line 68:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:Orso.b.schmid|Orso]], 2014.04.08:  It creates a named dash style definition. The name will appear also in the name list.
[[User:Orso.b.schmid|Orso]], 2014.04.08:  It creates a named dash style definition. This sets the name in both the name list and the dash style list. The parameter numPairs seems to be automatically filled depending on the count of pair values. In the example below it works with "0".
</remark>
</remark>


Line 74: Line 74:
<sample>
<sample>
<code lang="pas">
<code lang="pas">
SetDashStyle('My Dash Style', True, 1, 1", 1/4", 1/4", 1/4");
SetDashStyle('My Dash Style', True, 0, 1", 1/4", 1/4", 1/4");
</code>
</code>
</sample>
</sample>

Revision as of 15:42, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetDashStyleN creates a new linestyle in a Vectorworks document. Parameter name defines the name of the linestyle, parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs defining the linestyle.


The linestyle is defined by up to five black/white length pairs, which are specified in parameters pair1 through pair5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs.

PROCEDURE SetDashStyleN(
name :STRING;
swt :BOOLEAN;
numPairs :INTEGER;
pair1 :REAL;
pair2 :REAL;
pair3 :REAL;
pair4 :REAL;
pair5 :REAL);
def vs.SetDashStyleN(name, swt, numPairs, pair1, pair2, pair3, pair4, pair5):
    return None

Parameters

name STRING
swt BOOLEAN
numPairs INTEGER
pair1 REAL
pair2 REAL
pair3 REAL
pair4 REAL
pair5 REAL

Remarks

Orso, 2014.04.08: It creates a named dash style definition. This sets the name in both the name list and the dash style list. The parameter numPairs seems to be automatically filled depending on the count of pair values. In the example below it works with "0".

Example

SetDashStyle('My Dash Style', True, 0, 1", 1/4", 1/4", 1/4");

Version

Availability: from Vectorworks 2010