VS:SetDashStyle: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add remark)
Line 62: Line 62:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User:Orso.b.schmid|Orso]], 2014.04.08:  It creates a generically named dash style. Use [[VS:SetDashStyleN]] to name the new style during creation.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 67: Line 73:
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
SetDashStyle(True,4,1&quot;,1/4&quot;,1/4&quot;,1/4&quot;);</code>
SetDashStyle(True, 0,1",1 /4", 1/4", 1/4");
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
Line 76: Line 83:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from MiniCAD4.0
Availability: from MiniCAD 4.0


</version>
</version>

Revision as of 15:02, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetDashStyle creates a new linestyle in a VectorWorks document. Parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs defining the linestyle.

The linestyle is defined by up to five black/white length pairs, which are specified in parameters b1,w1 through b5,w5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs.

PROCEDURE SetDashStyle(
swt :BOOLEAN;
numPairs :INTEGER;
pair1 :REAL;
pair2 :REAL;
pair3 :REAL;
pair4 :REAL;
pair5 :REAL);
def vs.SetDashStyle(swt, numPairs, pair1, pair2, pair3, pair4, pair5):
    return None

Parameters

swt BOOLEAN
numPairs INTEGER
pair1 REAL
pair2 REAL
pair3 REAL
pair4 REAL
pair5 REAL

Remarks

Orso, 2014.04.08: It creates a generically named dash style. Use VS:SetDashStyleN to name the new style during creation.

Example

VectorScript

SetDashStyle(True, 0,1",1 /4", 1/4", 1/4");

Python


Version

Availability: from MiniCAD 4.0