VS:SetDLComponentPenColors

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fore and back colors of the left and right side pens of the component at index in the Double Line Preferences.

FUNCTION SetDLComponentPenColors(
index :INTEGER;
leftPenForeColor :INTEGER;
leftPenBackColor :INTEGER;
rightPenForeColor :INTEGER;
rightPenBackColor :INTEGER) : BOOLEAN;
def vs.SetDLComponentPenColors(index, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
    return BOOLEAN

Parameters

index INTEGER The index of the component.
leftPenForeColor INTEGER The fore color of the left pen.
leftPenBackColor INTEGER The back color of the left pen.
rightPenForeColor INTEGER The fore color of the right pen.
rightPenBackColor INTEGER The back color of the right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:GetDLComponentPenColors

VS Functions: [[VS:GetDLComponentPenColors]]