VS:SetDLComponentPenColors

From Vectorworks Developer
Revision as of 21:56, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fore and back colors of the left and right side pens of the component at index in the Double Line Preferences.

FUNCTION SetDLComponentPenColors(
index :INTEGER;
leftPenForeColor :INTEGER;
leftPenBackColor :INTEGER;
rightPenForeColor :INTEGER;
rightPenBackColor :INTEGER) : BOOLEAN;
def vs.SetDLComponentPenColors(index, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
    return BOOLEAN

Parameters

index INTEGER The index of the component.
leftPenForeColor INTEGER The fore color of the left pen.
leftPenBackColor INTEGER The back color of the left pen.
rightPenForeColor INTEGER The fore color of the right pen.
rightPenBackColor INTEGER The back color of the right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:GetDLComponentPenColors

VS Functions: [[VS:GetDLComponentPenColors]]