VS:SetCustomRWPrefs

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the current custom RenderWorks rendering preferences from data passed in.

PROCEDURE SetCustomRWPrefs(
VAR useTextures :BOOLEAN;
VAR useTransparency :BOOLEAN;
VAR useShadows :BOOLEAN;
VAR useRayTracing :BOOLEAN;
VAR useAntiAliasing :BOOLEAN;
VAR useDithering :BOOLEAN;
VAR tessellationDetail :INTEGER;
VAR shadowStyle :INTEGER;
VAR rayTracingRecursion :INTEGER);
def vs.SetCustomRWPrefs():
    return (useTextures, useTransparency, useShadows, useRayTracing, useAntiAliasing, useDithering, tessellationDetail, shadowStyle, rayTracingRecursion)

Parameters

useTextures BOOLEAN
useTransparency BOOLEAN
useShadows BOOLEAN
useRayTracing BOOLEAN
useAntiAliasing BOOLEAN
useDithering BOOLEAN
tessellationDetail INTEGER
shadowStyle INTEGER
rayTracingRecursion INTEGER

Version

Availability: from Vectorworks 2014