VS:SetCursor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
Line 10: Line 10:
|+ Table - Cursor Styles
|+ Table - Cursor Styles
! Cursor Style
! Cursor Style
! Style Flag
! cursor parameter value
|-
|-
| Large Cross
| Large Cross
| LgCrossC
| 1307
|-
|-
| Small Cross
| Small Cross
| SmCrossC
| 1310
|-
|-
| Watch
| Watch
| WatchC
| 1311
|-
|-
| Text Bar
| Text Bar
| TextBarC
| 1312
|-
|-
| Arrow
| Arrow
| ArrowC
| 1309
|-
|-
| Hand
| Hand
| HandC
| 1308
|}
|}



Latest revision as of 20:28, 3 February 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetCursor changes the appearance of the screen cursor.

Table - Cursor Styles
Cursor Style cursor parameter value
Large Cross 1307
Small Cross 1310
Watch 1311
Text Bar 1312
Arrow 1309
Hand 1308
PROCEDURE SetCursor(
cursor :INTEGER);
def vs.SetCursor(cursor):
    return None

Parameters

cursor INTEGER Cursor style setting.

Example

VectorScript

SetCursor(LgCrossC);

Python


Version

Availability: from All Versions