VS:SetControlData

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the data for the specified extended control item.

This function can only be called from within the dialog event handler subroutine.

PROCEDURE SetControlData(
dialogID :LONGINT;
itemID :LONGINT;
data :LONGINT);
def vs.SetControlData(dialogID, itemID, data):
    return None

Parameters

dialogID LONGINT The index of the dialog containing the control.
itemID LONGINT The index of the dialog control item.
data LONGINT New data for the control item.

Remarks

This function supports the following control types:

  • color button -- the data is a 32-bit number of the red/green/blue components represented as 8-bit numbers
  • slider -- the data is the slider position
  • image -- the data is the ID of the image resource being displayed.

Version

Availability: from VectorWorks9.0

See Also

VS:GetControlData

[[VS:GetControlData]]