VS:SetControlData

From Vectorworks Developer
Revision as of 21:51, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the data for the specified extended control item.

In image controls, for example, this call can be used to set the ID of the image resource being displayed.

This function can only be called from within the dialog event handler subroutine.

PROCEDURE SetControlData(
dialogID :LONGINT;
itemID :LONGINT;
data :LONGINT);
def vs.SetControlData(dialogID, itemID, data):
    return None

Parameters

dialogID LONGINT The index of the dialog containing the control.
itemID LONGINT The index of the dialog control item.
data LONGINT New data for the control item.

Remarks

[DWD 1/20/00]

Version

Availability: from VectorWorks9.0