VS:SetControlData

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the data for the specified extended control item.

In image controls, for example, this call can be used to set the ID of the image resource being displayed.

This function can only be called from within the dialog event handler subroutine.

PROCEDURE SetControlData(
dialogID :LONGINT;
itemID :LONGINT;
data :LONGINT);
def vs.SetControlData(dialogID, itemID, data):
    return None

Parameters

dialogID LONGINT The index of the dialog containing the control.
itemID LONGINT The index of the dialog control item.
data LONGINT New data for the control item.

Remarks

[DWD 1/20/00]

Version

Availability: from VectorWorks9.0