VS:SetControlData: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(One intermediate revision by the same user not shown)
Line 7: Line 7:
<desc>
<desc>
Sets the data for the specified extended control item.  
Sets the data for the specified extended control item.  
In image controls, for example, this call can be used to set the ID of the image resource being displayed.


This function can only be called from within the dialog event handler subroutine.</desc>
This function can only be called from within the dialog event handler subroutine.</desc>
Line 43: Line 41:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[DWD 1/20/00]</remark>
This function supports the following control types:
* color button -- the data is a 32-bit number of the red/green/blue components represented as 8-bit numbers
* slider -- the data is the slider position
* image -- the data is the ID of the image resource being displayed.
</remark>


-----------------------------------------------------------------------------------------------------------
<seeAlso>
[[VS:GetControlData]]
</seeAlso>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>

Latest revision as of 21:05, 27 February 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the data for the specified extended control item.

This function can only be called from within the dialog event handler subroutine.

PROCEDURE SetControlData(
dialogID :LONGINT;
itemID :LONGINT;
data :LONGINT);
def vs.SetControlData(dialogID, itemID, data):
    return None

Parameters

dialogID LONGINT The index of the dialog containing the control.
itemID LONGINT The index of the dialog control item.
data LONGINT New data for the control item.

Remarks

This function supports the following control types:

  • color button -- the data is a 32-bit number of the red/green/blue components represented as 8-bit numbers
  • slider -- the data is the slider position
  • image -- the data is the ID of the image resource being displayed.

Version

Availability: from VectorWorks9.0

See Also

VS:GetControlData

[[VS:GetControlData]]