VS:SetConstrain

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetConstrain sets the active drawing constraints for the document. Each constraint is represented by an ASCII character identifier; these characters are assembled into a string which determines the constraints to be activated. VectorWorks Constraint Identifiers

Constraint Identifier
Snap To Grid A
Snap To Objects Q
Constrain Angle S
Snap Intersection W
Smart Points D
Snap To Distance E
Smart Edge F
Constrain Tangent R
PROCEDURE SetConstrain(
str :STRING);
def vs.SetConstrain(str):
    return None

Parameters

str STRING Constraint constant string.

Example

VectorScript

SetConstrain('QD');

{activates the snap objects and smart point constraints and deactivates the others}

Python


Version

Availability: from All Versions